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1.0

OBJECTIVE
This document outlines maintenance and installation of the ManufactPro database system.
MMC provides this document as guide to help understand the operation of client/server relational database software.
Specific procedures are the responsibility of the end users of MMC products.

2.0

SCOPE
This document is specific to the ManufactPro relational database system, a product of MMC, running on FileMaker
Pro.

3.0

MAINTENANCE PROCEDURE
By using the platform of FileMaker Pro to host your database solution, many of the traditional maintenance routines
of big databases can be avoided and minimized. Re-indexing for example, in accomplished on the fly or as needed
on the FileMaker platform.
Some maintenance still needs to be done to keep your system running smoothly. Some of these tasks can be
automated using the Server Console and backup software, some can be done manually by IT or the MFP
administrator or MMC. It is up to you to decide who does the maintenance and when.
The “Wait till it crashes” option is not very professional and can result in downtime for your operations, data loss
and very expensive emergency service bills. Almost every crash we have seen could have been avoided by a couple
of the routines below.
Basic computer OS skills are needed to perform these tasks: running applications, starting and stopping services,
copying and renaming files, writing backup media, and restoring from backup media. Maintenance requires a
workstation with the full version of FileMaker Pro and full version of the MMC software installed If you choose to
limit user functionality via the package definition format file or by doing network installation in a managed MS
environment, at least one machine is required on site to be configure to our specifications. If your IT department
cannot provide this, do not use our software.

Suggested Schedule:
Daily:
Backup a closed daily copy of databases to backup media. Use the FM server console to write backups at a specific
time and to a specific location (can be to another server on the LAN). Reason: restore data due to user/admin errors;
restore data in event of hard disk crash.
Weekly:
Reboot the server. Clears any memory leaks and instabilities. Can do monthly on Unix or very stable windows
machines. Do a cold reboot, which is a shutdown, wait 2 minutes and then restart. Reason: improves speed and
performance. Unstable machines can do very weird things.
Monthly :
Run MFP specific maintenance scripts. Doc Log, Parts, and Part Lots are examples. A button located on Reports
screen in each database, usually labeled “file maintenance” runs the scripts. A master Maintenance button is located
in the Preference section of the MFP. Reason: performs error check and writes calculated data to local indexed
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fields. Very important if the administrator is working unlocked and not using the user interface for data entry.
Corrects many synchronization issues caused by admins who “trick” the system.

Quarterly:
Compress and swap large log files. Reason: improves performance and reduces disk fragmentation.
Annually:
Move all data into a clean structure. Contact MMC to do this. Reason: prevents data corruption due to file damage
As needed:
Document any design changes to the files. This is extremely important to prove the change control trail if you have a
validated system and to allow MMC to move your customization to a new structure during annual maintenance or
upgrade.
Apply bug fixes or updates from MMC.
Apply bug fixes or updates from FileMaker Inc.

4.0

MAINTENANCE HOW TO’S

Note: These procedure involve make copies of your MFP system and you need to take care to make sure there is only one copy of the system
available for user access, this includes local drives. FileMaker is a little too smart and will open local copies and networked copies at the
same time—a big mess. Prevent this by renaming all files or compressing and deleting originals.

Compress and swap
Stop FileMaker Server
Copy the entire system to a client
Open like normal, but use full control and point to the local copy of a_Home.fp5
Open the file to compress using a_Home.fp5
Select File>Save as>Choose compressed from the menu. Click OK.
Do this for all large log files.
Exit FileMaker
Rename the current files.
Rename the new compressed files to the exact name as the original.
Remove the original uncompressed files from the directory, save in case of problems.
Copy the entire system back to the server
Start FileMaker Server.

Restore from a backup
Stop FileMaker Server
Copy the entire system to an unshared directory and compress.
Find the most recent copy on your tape and restore to a hard drive.
Copy this to the FileMaker Server directory on the server
Start FileMaker Server

Update a file
This is if MMC sends you an update or critical bug fix.
Stop FileMaker Server
Read the instructions with the update, this will tell you what to rename files and where to put them
Run the update per the instructions
Copy the updated files back to the server
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Start FileMaker Server.

Do a design change
Minor design changes can be accomplished live online. Document the change.
Major changes must be done off line
It is MMC’s policy to always keep an unused copy of a system we maintain for design changes and backup purposes.
The reason is complex, but lies in the fact that FileMaker databases contain the data, the structure, the user interface and
the reports all in one place. The structure can be damaged or degraded in the normal production environment use to
thousands of opens and closes, server crashes and disk errors.
This is the basic software design routine we use
Write the specification
Make the change
Test the change
Document the test
Stop FileMaker Server
Copy the affected files to your offline copy
Import data
Reset counters
Run conversion routines or update scripts
Copy the updated files back to the server
Start FileMaker Server.
Test again live

Recover a file
FileMaker has a routine to recover damaged files. This must be done offline in single user mode.
Symptoms:
Buttons and scripts behave strangely
Unexpected crashes
Counter do not work
Some records display as blank
It is the policy of MMC to move data that has been recovered into the original unused files rather than reuse the
recovered files. While this can work for a while, repeated crashes and data loss may occur.
Stop FileMaker Server
Copy the entire system to a client
Open like normal, but use full control and point to the local copy of a_Home.fp5
Open the file to recover using a_Home.fp5
Select File>Recover. Click OK.
Do this for all damaged files.
Exit FileMaker
Rename the current files.
Rename the new recovered files to the exact name as the original.
Remove the original uncompressed files from the directory, save in case of problems.
Copy the entire system back to the server
Start FileMaker Server.

“Just doing one file or module”
Yes, this is possible. You can leave most of the system up and you may have seen MMC personnel doing this. Follow
the above procedures. Use the Remote Admin tool to open and close just one file or module. When opening and
working locally, you must set the local copy of FMP to no networking to prevent user from connecting to your machine.
This way of working requires have at least two client computers or switching the network preference at least 3 times per
event and restarting FileMaker Pro each time. Not recommended for beginners, it is too easy to make a mistake.

5.0

BASICS
Use the Remote Admin feature/plug in
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Use the remote admin tool to selectively close files for maintenance or changes.
Launch the FileMaker Pro application on the local machine. Do not open any network files.
Select File>Open>Host .
Select the server name at the top of the list.
Click Open.
Enter the server password.
The server remote control panel will now appear and you can close or open the desired databases using the buttons. It is
nice to send a message to other users if you are booting them off. To close the entire database, select the folder and click
Close.
Click Done.
The file(s) are now closed and can be opened on the server from your machine.
Open the server control panel again and open the file(s) on the server.
Close the server dialog and test your changes.

Start/Stop FileMaker Pro Server
Log on to the server
Select Programs>Administrative Tools>Services
Select FileMaker Server from the list
Click start or stop.
It can take a few minutes to disconnect all the users and close the files.

Rename files
Find the file using Explorer. Launch explorer by typing Windows key + E.
Click on the file once or type the F2 key
Right click and select rename
Type the new name.

6.0

WHEN THINGS GO WRONG
1. Use the remote control administration function from any client machine to see the statistics and if any or all of the files
are closed. This feature works via a plugin that is installed on every machine when using the MMC client installer. The
plugin is installed with the MMC client installer. It can also be installed from the Server CD-ROM on to a client as well.
Do not try to install it on to the server, it will not work unless there is a copy of FileMakerPro client on the server. To use
the remote control admin, launch FileMakerPro on the client. Select file>open>host>servername. Double click on the
server icon at the top of the list. Enter the password. Select open file and see if any databases are not open. Attempt to
open them by clicking once on them ,then click open.
2. If the files do not open, try starting and stopping services on the server. Select Start>Control
Panels>Services>FileMaker Server>Stop. Wait 2-5 minutes before restarting.
3. If this does not work. Shut down and restart the server. The databases should open automatically. Shut down and wait
2 minutes and then start up. Do not do a restart.
4. If this does not happen. Read the error messages and event logs and try to recover the problem databases. Use the
Event Viewer application. Launch FileMakerPro on a client and select File>Recover. You must rename the files exactly
as they were originally. Go to step one and try to open them on the server again. Move the data into your original files
or design copies as soon as possible
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5. If this does not work. Try restoring from backup.
6. If this does not work. Try reinstalling the server software.
7. If this does not work. Call MMC.

7.0

INSTALLATION—SERVER/CLIENT/MFP
For best performance, ManufactPro should be run on its own server using FileMakerPro Server. However, we have had
success in using a server that acts as a file server, print server, gateway, domain controller, or backup domain controller.
FileMaker Server will not run on a server with Microsoft Exchange installed and running. The reason is Exchange will
take 100% of the CPU for long periods of time—hours and prevent users access to the hosted databases.
If you are running Exchange, we suggest the following hardware setup:
Main Server(not running FileMaker Server): Raid 1 drives, 1GB Ram, Tape drive, Exchange, Domain Controller, IIS,
File Server. Example: Dell Poweredge 2600-$3500 as of 6/2004
Application Server (running FileMaker Server): IDE drive(s), 1 GB RAM, one network card, FileMaker Server, Backup
Domain Controller, Print Spooler,. Example: Dell Poweredge 1750-$1700 as of 6/2004
If you are not running Exchange, we suggest the following hardware setup:
Main Server (running FileMaker Server): Raid 1 drives, 1GB Ram, Tape drive, Domain Controller, IIS, File Server,
FileMaker Server. Example: Dell Poweredge 2600-$3500 as of 6/2004
Detailed specs are at the end of this document.

Installing the Server-Step 1
Login as Admin. Turn virus protection off. Insert the CD. Click Install. Choose custom to change installation location
from the default install: C:programs\filemaker. Do not drag or copy and paste this or any application, the application will
not run and the Registery keys will become disconnected. Reinstall if you want to move the directory. Install only one
copy.
On some servers, the application may need an admin level password to do things like write backup to the hard disk or to a
share. To configure this, find the application (FileMaker Server), right click, open the properties sheet and enter a
password or assign the app to an admin level group.
Install on hardware certified by Microsoft. No AMD processors.
Problems can arise with multiple network cards. Removing/disabling all but one card solves the problem. Have only one
adapter per protoco(tcp/ip) installed. FileMaker cannot be told which adapter to use. It is possible to install other
adapters after the server is up and running and one client is connected. Contact MMC for more information.

Configuring the Server Software-Step 2
Select Start>Programs>FileMaker>FileMakerConsole. Click on each wizard to setup. Set the values below or the custom
values for your network. Click “apply” then “OK”.
Set users to 25
Set files to 100.
Remote admin to yes. Password company initials.
Allow hosting single user files
Ram to 40mb. Do not give more. FileMaker Server 6 can only use up to 40MB. Server 7 can use up to 70% of installed
RAM.
Network Protocol: TCP
Service starts automatic
Note: If IE5.5 is installed, the wizards do not work. Install IE 6.0 or highter or use the buttons on the toolbar to get to the
properties sheet. Or right click in the window to get to the properties sheet.
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Install the MFP Databases-Step 3
Copy the databases into the FileMakerPro5 Server Folder. The server will open all files in this directory and one level
down. Install only one copy. Do not change the names of the files. If installing from a CD, select all files and set the
read only bit (properties: right click) to “not read only”. Install and share the FM_Support directory.
Select Start>Programs>Services and start the FileMaker Server Service.

Create Backup Schedule, Configure Backup and Virus Apps.-Step 4
Create an unshared directory on the server called fm_bu.
Create directories in fm_bu called daily and weekly.
Using the server console to create a daily and weekly backup. Test by right clicking the schedule and select “Run Now”.
Most backup software should skip open files, ie all the databases, so the daily and weekly directories are put on the tape
instead. Make sure your backup software skips open files.
Configure the backup software (Veritas/Symantec) and the virus software (Symantec) to skip the FileMaker Server
directory at c:\\Programs\FileMaker\FileMaker Server x\. If you do not do this, the databases can be corrupted, damaged
and you can loose data and cause your system to be non-functional. Pattern matching virus scanning software is known to
alter the data and schema of the database files. Do not let this happen.

Set Permissions for the Server Directory-Step 5
Share the FileMaker Server directory. Allow full control to sys admins and filemaker admins. Do not give anyone else
read or any other kind of access. Apply the permissions to the directories only, not the files. FileMaker uses its own
permission scheme, not Windows. You must not allow the users to navigate to the database files and double click on
them. This is the wrong way to open networked databases and file damage and data corrupting will occur. Users open
the system by double clicking the file on their desktop or using the Hosts button.

Installing FileMaker on a Client machine
There are two steps: install the application and install MFP software.
Step 1-FileMaker app: Turn virus protection off. Insert the FileMaker application.CD. Click Install. The application
should be installed. MMC usually copies the application files and registration key to this location for easy network
installs. Command line and script installs possible, read the directions in the manual on the disk
Step 2-MFP app: Locate the FM_Support directory on your network to find the MMC installer or download the latest
version from our website: www.mmcpro.com. Double click MFP_Setup.exe. to run the Vise installer. You must install
the MFP software to use MMC products. This installer installs plugins, fonts and an opener file.
When upgrading, it is OK to leave older versions of FileMaker Pro on the machine, however, the MFP setup application
must be rerun. Older versions are treated as separate applications.

Moving Servers-FileMaker Server
Moving servers is no big deal. Install and configure FM Server on the new box. Stop services on the old box, copy the
databases to the new box, start service on the new box. All clients on the network should find the new box. OK to
change share name and IP address. In some cases, the first user to open the system must “locate” the new box the very
first time using Open>Hosts. After this first locate, everything works fine. Make sure you configure backups and
remove the old databases from the old box and disable the service. Running two FileMaker servers on the same network
is OK, but they must host different databases. If they host the same dbases, there is no way to correctly point, connect to
the new vs the old system. Do not do this. You will have some data entry in one system and some in another. It is
almost impossible to correct. Do not host 2 identical systems at the same time.

Moving Servers-Doc Control
Open the MFP and login as usual. Click Preferences>Preferences>Document Locations. Type to change the server
name. The MFP uses a UNC path to find the documents. The path is built from the server name in these fields and a
complex calculation to determine the file/directory names. The UNC path is rebuilt each time the open document feature
is used. You can run the maintenance script to re-write all paths at once.
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Custom Files
Some companies have custom databases that have been developed outside the scope of the MMS/MFP system. These
file are hosted on the same server and may have a button in the MFP home/main file. They are very specialized to the
owner who designed them, so please check with them first as to function, changes and access..

Passwords
Every file MMC develops has a master password used for design purposes. Using this password puts one at risk of data
deletion and design changes. Please check with the company contact for the master password or use the “Full Control”
opener file to open the database. The master password cannot be changed.

MMC Network Access
MMC requires a current and valid network logon to your domain. If we are installing software, we require permissions
that will let us do that. When we install or maintaining the server software, we require the admin password and physical
access to the server. If you want use to make customizations or do troubleshooting, we require remote access. We use
PC Anywhere and Windows Remote Desktop with or without VPN clients—we have the most widely used ones.

Known Issues:
FileMaker Server
1.
2.
3.
4.
5.

Internet Explorer 5.5 has a bug that will prevent the server wizards from running. Solution: Use property pane,
downgrade, upgrade.
The MMC-Microsoft Management Console is required to configure the server. Solutions: Install the MMC so snapins can be used.
The server app runs as a service, if it does not have the proper permissions, it cannot run. Solutions: Give it system
or admin permissions. Test by manually running backups and examine the event log.
Multiple network cards—NIC cards. FileMaker Server expects one network connection. Solutions: disable the extra
cards during install and active after FM Server is running.
Install on hardware certified by Microsoft. No AMD processors for the server. Solutions: use another box.

FileMaker Client
1.
2.

The memory cache on the client can drastically affect performance. Set to 9999k or use the MMC installer.
Window XP Service Pack 2 blocks the UDP and TCP port FileMaker uses to find Server. Solution: Open port
5003 for UDP and TCP.
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8.0 HARDWARE AND SOFTWARE REQUIREMENTS
Requirements for FileMaker Pro 8
Windows platform:
• Windows 2000 (SP4) or Windows XP (SP2)
Macintosh platform:
• Mac OS X 10.3.9 or Mac OS X 10.4.x
Requirements for FileMaker Server 8
Windows platform:
• Windows 2003 Server Standard Edition (SP1) or Windows 2000 Server (SP4)
Macintosh platform:
• Mac OS X 10.3.9 or Mac OS 10.4.X, or
• Mac OS X Server 10.3.9 or Mac OS X Server 10.4.x
ManufactPro is a server-intensive solution. Particularly for larger groups of users, we
recommend the latest server hardware and a fast network for best performance.
FileMaker 5.5-6.0 Server System Requirements
Windows
*
Pentium 3 or 4, 800 MHz or better
*
40MB of RAM in addition to OS—suggest 512MB-1GB
*
CD-ROM and hard disk drive
*
Windows 2000 Server or Advanced Server, Win 2003 Server.
∑
Network: Microsoft TCP/IP
∑
Free disk space: 100-200 MB (empty system is 30 MB)
∑
RAM: 40 Mb over OS needs.
∑
FileMaker 5.5-6.0 Client System Requirements
Windows
*
Intel-compatible computer Pentium 3 or 4
*
40MB of RAM required over the OS requirements-512 MB suggested.
*
Hard disk and CD-ROM drive
*
OS: Window 2000, 2000 Pro, XP, XP Pro, ME
∑
Network: TCP/IP
FileMaker 5.5-6.0 will also run on the Mac OSX platform.

9.0

RESOURCES
FileMaker manuals
FileMaker website

http://www.filemaker.com

MMC website

http://www.mmcpro.com

MMC documentation (in FM_Support and on CD)

